Add a widget of type file is not possible

This topic contains 8 replies, has 5 voices, and was last updated by  Patrick 1 year, 9 months ago. This post has been viewed 651 times

  • Author
    Posts
  • #158
     Lars 
    Participant

    As described in point 7 in the LoPy quick start guide. Not possible to select ‘file’ as widget type.

  • #162
     Arne Munch-Ellingsen 
    Keymaster

    Please specify in more detail what the problem is. I just tested the following and it worked as it should:
    1) Created a new thingtype
    2) Created a new thing in the thingtype created in 1)
    3) Clicked on the thing (to enter the dashboard for the thing) and added a widget of type “Files”.

    The “Files” widget correctly displays the configuration file (actually a complete program) for the LoPy.


    Telenor Start IoT team

  • #169
     Ruben 
    Participant

    Same problem here. I have created a “New Thing Type” and added a “Thing”. In the “+ Widget” section where is only four options:

    Thing Credentials
    Pie Chart Histogram
    Things Map Aggregations
    Events

  • #170
     Arne Munch-Ellingsen 
    Keymaster

    If you only see “Thing Credentials, Pie Chart Histogram, Things Map Aggregations and Events” you are trying to add a widget to the “Thing type” dashboard. You need to add a widget to the “Thing” dashboard in order to be able to create a widget of type “Files”. Refresh the “Thing type” dashboard and you should see a list of things. Click on the newly created thing in order to enter the thing dashboard.

  • #171
     Lars 
    Participant

    Never got my thing #1 to work, but I added thing #2. When clicking thing #2 I was able to add a widget of type file

  • #172
     Ruben 
    Participant

    Suddently it worked. I was not able to click directly on the “Thing” before, but after refreshing the browser a number of times i got a error, something like “device not found”. Then I logged out and in and it worked.

  • #173
     Arne Munch-Ellingsen 
    Keymaster

    Ok, the “device not found” and some other spurious error messages is a known problem. The reason is that with several minutes with inactivity you will be automatically logged out but the GUI does not handle this gracefully 🙁

  • #195
     Stavelin 
    Participant

    Had the same problem. If I click on the ID for “thing” #1 i get the message:

    No data available
    Most likely this thing has not connected yet

    Creating a 2nd “thing” gave the correct result.

  • #199
     Patrick 
    Participant

    Annoying bug indeed! Trapped in the same problem.
    The forum was useful. Creating a second “Thing” worked for me as well. Would be nice to document the bug in the guide 😉

You must be logged in to reply to this topic.

CONTACT US

Do you have any feedback? Please use the forum for technical support.

Sending

©2019 Telenor Start IoT - Privacy Policy - Research Privacy Notice - fueled by Benzin

Log in with your credentials

Forgot your details?