This topic has 2 replies, 2 voices, and was last updated 2 weeks ago by kajabugge. This post has been viewed 104 times

  • Author
    Posts
  • #723
     kajabugge
    Participant

    Hi,
    I was following the FIPY MQTT tutorial and got an error when uploading the code regarding the certificate files. I don`t remember the errors exactly but it was not able to read the files. Any ideas?

    #730
     tuvarambre
    Keymaster

    Hi,

    It is difficult for me to know what the problem is exactly, but it might have something to do with your file settings.

    First of all, I would check if the certificate files are in the cert folder.

    If they are, check that your file settings allow the .pem format. You can check this by going to “all commands” > “global settings” and check which file types are allowed in “sync_file_types” (line 18). If there is no .pem, add it, save and try to upload again.

    "sync_file_types": "py,txt,log,json,xml,html,js,css,mpy,pem"

    I hope this was helpful.

    #734
     kajabugge
    Participant

    Thanks for the help. I tried it and it works now!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

© 2020 Telenor Start IoT
 

Log in with your credentials

Forgot your details?