Tagged: ,

This topic has 1 reply, 1 voice, and was last updated 2 weeks, 5 days ago by am. This post has been viewed 72 times

  • Author
    Posts
  • #875
     am
    Participant

    Sorry For re-posting. I am adding more info about the error.

    I am testing Fipy with nb-iot and running the Coap. Everytime I try to run the code I get this error.

    Initializing filesystem as FatFS!
    Traceback (most recent call last):
    File “main.py”, line 1, in <module>
    File “/flash/lib/telenor.py”, line 3, in <module>
    ImportError: cannot import name Coap
    Pycom MicroPython 1.20.0.rc13 [v1.9.4-94bb382] on 2019-08-22; FiPy with ESP32

    I tried with CATM1 same error.

    Fipy firmware

    (sysname=’FiPy’, nodename=’FiPy’, release=’1.20.0.rc13′, version=’v1.9.4-94bb382 on 2019-08-22′, machine=’FiPy with ESP32′, lorawan=’1.0.2′, sigfox=’1.0.1′)

    Modem firmware

    Welcome to the SQN3330 firmware updater [1.2.6] >>>
    >>> FiPy with firmware version 1.20.0.rc13
    Your modem is in application mode. Here is the current version:
    UE6.0.0.0
    LR6.0.0.0-41019

    lte.isattached() always give false even when I try to REPL

    from network import LTE
    lte = LTE()
    lte.deinit()
    lte.init()
    lte.attach(apn=”telenor.iot”, band=20)

    Any Ideas on how to fix this problem.

    #876
     am
    Participant

    The problem was fixed by installing fipy pybytes instead of legacy firmware.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

© 2020 Telenor Start IoT
 

Log in with your credentials

Forgot your details?