This topic has 1 reply, 2 voices, and was last updated 5 days, 2 hours ago by michaelstornes. This post has been viewed 53 times

  • Author
    Posts
  • #762

    Hi!
    I’ve managed to get my starter kit up and running, sending data to MIC. However, it will only work when connected to the PC where I’ve installed all the software from the tutorial. If I use a power bank, a mobile charger or any other USB power source it fails. I added some of the LED-code from the temperature sensor tutorial, and it seems to crash right after initiating the modem.

    Any thoughts on how to solve this issue?

    #765
     michaelstornes
    Participant

    Hi!

    I experienced this issue, and tried “everything” to solve it. Update the FiPy, the modem, the expansion board, flash the modem to NB-IoT. You name it.

    However, none of the above worked in the slightest (I did experience a new issue, solved by following the tips found here: https://startiot.telenor.com/forums/topic/trouble-attaching-to-lte-m-network/).

    In the end, my issue was solved my going to the source for help – the Pycom FiPy documentation on how to get started:
    https://docs.pycom.io/gettingstarted/connection/fipy/
    Here they state the following:
    – “When using the expansion board with a FiPy, you will need to remove the CTS and RTS jumpers as these interfere with communication with the cellular modem.”

    These jumpers are black plastic components sticking out on the top left (when looking at the illustration from the Pycom site). Look for the ones next to “CTS” and “RTS” written on the board, and just pull them straight up. They are a bit tough to pull out, but a tweezer did the trick.

    For me, it solved the issue immediately. I’ve had it running off a regular mobile charger for almost two days now.
    Hopefully it helps you as well! I’ve also sent a tip so that this info may be added in the tutorial, making it less of an issue going forward.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

© 2020 Telenor Start IoT
 

Log in with your credentials

Forgot your details?