Tagged: ,

This topic has 8 replies, 4 voices, and was last updated 3 days, 20 hours ago by tuvarambre. This post has been viewed 329 times

  • Author
    Posts
  • #508
     tuvarambre
    Keymaster

    I’m having trouble attaching my fipy to the lte-m network..
    It just says Attaching… and does not get any further.
    I have tried several SIM cards, expansion boards and antennas, but nothing seems to work.
    Anyone have any ideas what I can try next?

    #535
     Pontus
    Keymaster

    Hey there!

    What seems to work in situations like this is to update both the device and modem firmware on the FiPy to the latest release.

    You can find detailed instructions on the Pycom websites on how to do this:

    If for some reason it still doesn work you could try to “reset” the modem by issuing the following commands in the REPL:
    from network import LTE
    lte = LTE()
    lte.deinit()
    lte.init()
    lte.attach(apn="telenor.iot", band=20)

    You can then check if the device is attached with the following line:
    lte.isattached()

    It should return True if the modem is attached to the network.

    Hope it works! 🙂

    • This reply was modified 2 months, 2 weeks ago by tuvarambre.
    • This reply was modified 2 months, 2 weeks ago by tuvarambre.
    #606
     tuvarambre
    Keymaster

    Hi,
    Thank you for your input. The REPL commands did the trick. 🙂

    #761
     michaelstornes
    Participant

    Perfect! This solved my issue! I thought my sudden lack of LTE-attachment was due to an update of the expansion board (3.1), but apparently not. I should have come here sooner …

    #779
     helgesolevag
    Participant

    Hey
    I am new to this. It stops here. I have tried to update the firmware.
    Do I have the newest? Hope someone could help me out here 🙂

    Connecting to COM5…
    Smart Provisioning started in the background
    See https://docs.pycom.io/smart for details
    Running example code…
    Modem in using LTE-M firmware (UE5.0.0.0d/LR5.1.1.0-39529).
    Started connecting to the network…
    > AT+CFUN=0
    >> OK
    > AT!=”clearscanconfig”
    >> OK
    > AT!=”addscanfreq band=20 dl-earfcn=6352″
    >> OK
    > AT+CGDCONT=1,”IP”,”telenor.iotgw”
    >> OK
    > AT+CFUN=1
    >> OK
    > AT+CSQ
    >> +CSQ: 99,99
    >> OK
    Attaching…

    #780
     Pontus
    Keymaster

    Hi!

    Did you also update the modem firmware (not just the FiPy board firmware)?
    You can follow the steps described here: https://docs.pycom.io/tutorials/lte/firmware/
    We’ve made the modem firmware available in this GitHub repository, since Pycom has password protected the files on their server: https://github.com/TelenorStartIoT/sequans-modem-firmware

    In your case you want the LTE-M (Cat M1) firmware.

    You can also try the commands that are described at the top of this thread. You can access the REPL (the window where you can read the program output) by pressing CTRL + C. This will stop the program and give you three arrows >>> where you can type your Python code line-by-line. It should look like this if you’ve entered the REPL successfully:

    Pymakr REPL in VSCode

    Hope this helps!

    #790
     helgesolevag
    Participant

    Error-line14
    I dont know if you see this screenshot in the link above, but I got a error in line 14.
    Still the same error message: Attaching…
    I have updated the firmware
    Modem in using LTE-M firmware (UE5.0.0.0d/LR5.1.1.0-41065).
    What do I do next??

    #791
     helgesolevag
    Participant

    An update….
    I run the code from your answer to tuvarambre above:
    That returned False

    #807
     tuvarambre
    Keymaster

    Hi Helge,

    Sorry for the late answer. This is a question we don’t have a simple answer to yet.
    We experience that it often helps to remove the plastic caps on RTS and CTS on your expansion board.
    You should also check that the antenna and sensor-pins are in the correct slots.

    If none of the above works we recommend you try with another SIM card. You can order a new free SIM card here: Start IoT SIM card

    I hope one of the above solutions will solve the problem.
    Keep us posted, and we will investigate further to find other possible solutions.

    \Tuva

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

© 2020 Telenor Start IoT
 

Log in with your credentials

Forgot your details?