This topic has 4 replies, 2 voices, and was last updated 7 months ago by steffennilsen. This post has been viewed 576 times

  • Author
    Posts
  • #1139
     eysteinlinnerud
    Participant

    Hi
    Bought the package from Telenor some days ago. The ublox modem does not respond at all. I’ve tried both the sketch in the tutorial Get Started With the Arduino MKR NB 1500 Dev-Kit (MQTT/TLS 1.2 over LTE-M) and other sketches like DebugATCommandsSARA from https://forum.arduino.cc/index.php?topic=597738.15 without any respons from the modem.
    What to do?
    regards Eystein Linnerud

    #1141
     steffennilsen
    Participant

    Hey Eystein.

    First of all, lets get some assertions out of the way. As you have been trying different program we can assert that you have a working usb connection and can program the Arduino unit. I assume you are using the Arduino IDE. Do you use the same baud rate in the program and while communicating with the program (say 9600 or 115200)? Can you read serial communication from the Arduino if say doing Serial.println("test");? When sending over the serial, can you echo the sent data to confirm the data you read is the same you sent? Have you checked line ending in the Serial Monitor LF/LFRF?

    With those questions out of the way, confirm that you are sending data trough the SerialSARA interface. SerialSARA expands to the Serial2 interface, you can try to write to this serial interface.

    If these pointers dont work out, we can try another program before we try another approach.

    – Steffen

    #1144
     steffennilsen
    Participant

    obviously LF/LFCR, not LF/LFRF..

    #1145
     eysteinlinnerud
    Participant

    Hi Steffen

    I’ve written a control application for a Wallas heater on an D1 Mini NodeMcu WIFI ESP8266. The application is communicating with a MQTT broker on a Raspberry PI via MQTT over WIFI. I bought the StartIOT Arduino MKR NB 1500 Dev-Kit to build a communication solution to control the application from remote. The Raspberry PI and the Arduino MKR NB 1500 will communicate over USB. This is nearly solved. So all Arduino stuff is familiar.

    The real problem is that the UBlox modem deny to answer SerialSARA AT Commands. Power off/on MKR NB 1500 and/or reset button activating does not resolve what I consider is a deadlock or a serious HW/Firmware error.

    One possible problem can be that I tried a SMS-Send sketch without knowing the PIN. Maybe I have to get PUK2 to resolve that.

    I hope you can give me a way to get the MKR NB 1500 working.

    Regards Eystein L.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

© 2021 Telenor Start IoT
 

Log in with your credentials

Forgot your details?